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Getting Started 

• Download example data file ‘noise.silo’ 
– http://portal.longhorn.tacc.utexas.edu/training/ 

– Right-click, Save link as… 

 

 

• Open VisIt 
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http://www.tacc.utexas.edu/~gregj/training


VisIt 

Today we will: 

• Create contours for a scalar 
variable 

• Create isosurfaces for a scalar 
variable 

• Clip and slice the isosurfaces 

• Use glyphs to display a vector field 

• Use streamlines to show flow 
through a vector field 

• Edit annotations and background 

• Add slices to show variable values 
over a plane 

• Create volume rendering  
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VisIt 

Open the file (and display 
information) 

Noise.silo 

• Click File -> Open 
file 

• Select noise.silo 

• Click OK 

• Note name of file under -> 
Active source 

• Click File information 

• Close Window 

 

 

 
01/20/2012 4 



VisIt 

Open the file (and display 
information) 

Noise.silo 

• Click File -> Open 
file 

• Select noise.silo 

• Click OK 

• Note name of file under -> 
Active source 

• Click File information 

• Close Window 

 

 

 

 
01/20/2012 5 



VisIt 

Open the file (and display 
information) 

Noise.silo 

• Click File -> Open 
file 

• Select noise.silo 

• Click OK 

• Note name of file under -> 
Active sourceurce 

• Click File information 

• Close Window 

 

 

 

 
01/20/2012 6 



VisIt 

Open the file (and display 
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VisIt 

Create contour 

• Click Add -> Contour -> 
hardyglobal 

• Click Draw 

• Double click on Contour (or 
Right-click ->Edit plot 
description) 

• Under select by choose ->N 
Levels enter 5 

• Change the opacity levels 

• Click Apply 

• Click Dismiss 

• Click Delete 
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Create contour 
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VisIt 

Create contour 
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VisIt 

Create contour 
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N Levels 
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VisIt 

Create contour 

• Click Add -> Contour -> 
hardyglobal 

• Click Draw 

• Double click on Contour (or 
Right-click ->Edit plot 
description) 

• Under select by choose ->N 
Levels enter 5 

• Change the opacity levels 
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• Click Delete 

 

 

 

 

 

 

Opacity 
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VisIt 

Create contour 
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VisIt 

Create contour 

• Click Add -> Contour -> 
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• Double click on Contour (or 
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Levels enter 5 

• Change the opacity levels 

• Click Dismiss 

• Click Delete 
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VisIt 

Create Pseudocolor and 
isosurfaces 

• Click Add -> Pseudocolor 
-> hardyglobal 

• Click Draw 

• Click Operator -> 
Slicing -> Isosurface 

• Click Draw 

• Click Arrow to expand 

• Double-Click Isosurface 

• Under select by choose -
>Percent(s) enter 50 

• Click Apply & Dismiss 
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VisIt 

Create Pseudocolor and 
isosurfaces 
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VisIt 

Create Pseudocolor and 
isosurfaces 
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VisIt 
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VisIt 
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VisIt 

Create Pseudocolor and 
isosurfaces 

• Click Add -> Pseudocolor 
-> hardyglobal 

• Click Draw 

• Click Operator -> 
Slicing -> Isosurface 

• Click Draw 

• Click Arrow to expand 
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>Percent(s) enter 50 
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VisIt 

Create Pseudocolor and isosurfaces 

• Double-Click -> Pseudocolor 

• Change Opacity 

• Click Apply 

• Unselect Apply 

operators/Selection to all 

plots 

• Click Add -> Pseudocolor -> 
hardyglobal 

• Click Operator -> Slicing -> 
Isosurface 

• Click Arrow to expand 

• Double-Click Isosurface 

• Under select by choose -
>Percent(s) enter 80 

• Click Apply -> Dismiss -> 
Draw 
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VisIt 

Create Pseudocolor and isosurfaces 
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VisIt 

Create Pseudocolor and isosurfaces 

• Double-Click -> Pseudocolor 

• Change Opacity 

• Click Apply 

• Unselect Apply 

operators/Selection to all 

plots 

• Click Add -> Pseudocolor -> 
hardyglobal 

• Click Operator -> Slicing -> 
Isosurface 

• Click Arrow to expand 

• Double-Click Isosurface 

• Under select by choose -
>Percent(s) enter 80 

• Click Apply -> Dismiss -> 
Draw 

 

 01/20/2012 24 



VisIt 

Create Pseudocolor and isosurfaces 
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VisIt 

Create Pseudocolor and isosurfaces 
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VisIt 

Create Pseudocolor and isosurfaces 

• Double-Click -> Pseudocolor 

• Change Opacity 

• Click Apply 

• Unselect Apply 

operators/Selection to all 

plots 

• Click Add -> Pseudocolor -> 
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• Click Operator -> Slicing -> 
Isosurface 
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VisIt 

Clip Isosurfaces 

• Select -> apply operators 
and selection to all 

plots 

• Click Operators -> 
Selection -> Clip 

• Click Draw 

• Double-Click -> Clip 

• Click Plane 2 

• Click Apply & Dismiss 

• Click x (to delete) 

• Click Draw 
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VisIt 

Clip Isosurfaces 

• Select -> apply operators 
and selection to all 

plots 
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Selection -> Clip 
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VisIt 

Clip Isosurfaces 
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VisIt 

Clip Isosurfaces 
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plots 
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VisIt 

Clip Isosurfaces 
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VisIt 

Clip Isosurfaces 

• Select -> apply operators 
and selection to all 

plots 
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Selection -> Clip 

• Click Draw 

• Double-Click -> Clip 

• Click Plane 2 

• Click Apply & Dismiss 

• Click x (to delete) 

• Click Draw 
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VisIt 

Slice Isosurfaces 

• Click Operators -> 
Slicing -> Slice 

• Click Draw 

• Double-Click -> Slice 

• Select Z-Axis & 
Unselect Project to 
2D 

• Click Apply 

• Click Dismiss 
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VisIt 

Slice Isosurfaces 

• Click Operators -> 
Slicing -> Slice 

• Click Draw 

• Double-Click -> Slice 

• Select Z-Axis & 
Unselect Project to 
2D 

• Click Apply 

• Click Dismiss 
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VisIt 

Slice Isosurfaces 

• Click Operators -> 

Slicing -> Slice 

• Click Draw 

• Double-Click -> Slice 

• Select Z-Axis & 

Unselect Project to 
2D 

• Click Apply 

• Click Dismiss 
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VisIt 

Slice Isosurfaces 

• Click Operators -> 
Slicing -> Slice 

• Click Draw 

• Double-Click -> Slice 

• Select Z-Axis & 
Unselect Project to 
2D 

• Click Apply 

• Click Dismiss 
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VisIt 

Create Glyph of Vector 

• Unselect Apply operators/ 
selection to all plots 

• Click Add -> Vector -> 
airVfGradient 

• Click Draw 

• Double click on Vector 

• Under Vector amount enter 
1000 

• Click Apply 

• Click Dismiss 

• Click Hide/Show 
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VisIt 

Create Glyph of Vector 

• Unselect Apply operators/ 
selection to all plots 

• Click Add -> Vector -> 
airVfGradient 

• Click Draw 

• Double click on Vector 

• Under Vector amount enter 
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• Click Apply 

• Click Dismiss 

• Click Hide/Show 
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VisIt 

Create Glyph of Vector 
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VisIt 

Create Glyph of Vector 

• Unselect Apply operators/ 
selection to all plots 

• Click Add -> Vector -> 
airVfGradient 

• Click Draw 

• Double click on Vector 

• Under Vector amount enter 
1000 

• Click Apply 

• Click Dismiss 

• Click Hide/Show 
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VisIt 

Create Streamlines 

• Click Add -> Streamline -> grad 

• Double click on Streamline 

• Under Source Type Select Plane 
Enter: 

– Samples in X and Y: 15 

– Distance in X and Y: 20 

– Streamline Direction Both 

– Select limit Maximum Time Step 

• Click Apply 

• Click Dismiss 

• Click Draw and Dismiss warning 

• Double click on Streamline 
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VisIt 

Create Streamlines 

• Click Add -> Streamline -> grad 

• Double click on Streamline 

• Under Source Type Select Plane 
Enter: 

– Samples in X and Y: 15 

– Distance in X and Y: 20 

– Streamline Direction Both 

– Select limit Maximum Time Step 

• Click Apply 

• Click Dismiss 

• Click Draw and Dismiss warning 

• Double click on Streamline 
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VisIt 

Create Streamlines 

• Click Add -> Streamline -> grad 

• Double click on Streamline 

• Under Source Type Select Plane 

• Enter: 
– Samples in X and Y: 15 

– Distance in X and Y: 20 

– Streamline Direction Both 

– Select limit Maximum Time Step 

• Click Apply 

• Click Dismiss 

• Click Draw and Dismiss warning 
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VisIt 

Create Streamlines 

• Click Add -> Streamline -> grad 
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VisIt 

Create Streamlines 

• Click on Appearance 

• Under Draw as select Tubes -> 
Radius 0.005 

• Unselect Show seeds 

• Unselect Legend 

• Click Apply 

• Under Data Value select Variable 
-> Scalars -> hardyglobal 

• Click Apply 

• Under Color -> Color table, click 
Default Choose bluehot 

• Click Apply & Dismiss 
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VisIt 
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Create Streamlines 

• Click on Appearance 

• Under Draw as select 
Tubes -> Radius 0.005 

• Unselect Show seeds 

• Unselect Legend 

• Click Apply 

• Under Data Value select 
Variable -> Scalars -

> hardyglobal 

• Click Apply 

• Under Color -> Color table, 
click Default Choose 
bluehot 

• Click Apply & Dismiss 
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Create Streamlines 
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• Unselect Show seeds 

• Unselect Legend 

• Click Apply 

• Under Data Value select 
Variable -> Scalars -

> hardyglobal 

• Click Apply 

• Under Color -> Color table, 
click Default Choose 
bluehot 

• Click Apply & Dismiss 

 

 

 

 

 

 

 

 



VisIt 

Background Color and Legend 

• Click on Controls -> 
Annotation 

• Click on Colors 

• Select Black for Background and 
White for Foreground 

• Click Apply 

• Click on General 

• Click no annotations 

• Select legend 

• Click Apply & Dismiss 

• Hide Pseudocolor Plots 
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VisIt 

Background Color and Legend 
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• Hide Pseudocolor Plots 
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VisIt 
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VisIt 
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VisIt 
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VisIt 

Create Slice 

• Click Add -> Pseudocolor -> 
grad_magnitude 

• Click Draw 

• Click Operator -> Slicing -> 
Slice 

• Double click on Slice 

• Select Z Axis 

• Unselect project to 2D 

• Click Apply & Dismiss 

• Click Draw 

• Click Hide/Show 
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Create Slice 

• Click Add -> Pseudocolor -> 
grad_magnitude 

• Click Draw 

• Click Operator -> Slicing -> 
Slice 

• Double click on Slice 

• Select Z Axis 

• Unselect project to 2D 

• Click Apply & Dismiss 

• Click Draw 

• Click Hide/Show 

 

 

 
01/20/2012 58 



VisIt 

Create Slice 
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Create Slice 

• Click Add -> Pseudocolor -> 
grad_magnitude 

• Click Draw 

• Click Operator -> Slicing -> 
Slice 

• Double click on Slice 

• Select Z Axis 

• Unselect project to 2D 

• Click Apply & Dismiss 

• Click Draw 

• Click Hide/Show 

 

 

 
01/20/2012 60 



VisIt 

Create Slice 
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VisIt 

Create Slice 

• Click Add -> Pseudocolor -> 
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VisIt 

Create Volume Rendering 

• Click Add -> Volume -> 
grad_magnitude 

• Click Draw 

• Double click on Volume 

• Click on 1D transfer function 

• Change Transfer Function (Under 
Opacity) 

• Click Apply 

• Click Dismiss 
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VisIt 

Create Volume Rendering 

• Click Add -> Volume -> 
grad_magnitude 

• Click Draw 

• Double click on Volume 

• Click on 1D transfer function 

• Change Transfer Function (Under 
Opacity) 

• Click Apply 

• Click Dismiss 
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VisIt 

Create Volume Rendering 

• Click Add -> Volume -> 
grad_magnitude 

• Click Draw 

• Double click on Volume 

• Click on 1D transfer function 

• Change Transfer Function (Under 
Opacity) 

• Click Apply 

• Click Dismiss 
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VisIt 

Create Volume Rendering 

• Click Add -> Volume -> 
grad_magnitude 

• Click Draw 

• Double click on Volume 

• Click on 1D transfer function 

• Change Transfer Function (Under 
Opacity) 

• Click Apply 

• Click Dismiss 
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VisIt 

Create Volume Rendering 

• Click Add -> Volume -> 
grad_magnitude 

• Click Draw 

• Double click on Volume 

• Click on 1D transfer function 

• Change Transfer Function (Under 
Opacity) 

• Click Apply 

• Click Dismiss 
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Questions? 

• More tutorials available: 

– https://wci.llnl.gov/codes/visit/manuals.html 

 

• More information: 
–  http://visituers.org 

 

• More help: 
– Visit User mailing list: visit-users@email.ornl.gov 
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